{"id":"SUSE-SU-2024:2636-1","summary":"Security update for bind","details":"This update for bind fixes the following issues:\n\nUpdate to release 9.18.28\n\nSecurity fixes:\n\n- CVE-2024-0760: Fixed a flood of DNS messages over TCP may make the server unstable (bsc#1228255)\n- CVE-2024-1737: Fixed BIND's database will be slow if a very large number of RRs exist at the same name (bsc#1228256)\n- CVE-2024-1975: Fixed SIG(0) can be used to exhaust CPU resources (bsc#1228257)\n- CVE-2024-4076: Fixed assertion failure when serving both stale cache data and authoritative zone content (bsc#1228258)\n\nChangelog:\n\n  * Command-line options for IPv4-only (named -4) and IPv6-only\n    (named -6) modes are now respected for zone primaries,\n    also-notify, and parental-agents.\n  * An RPZ response’s SOA record TTL was set to 1 instead of the\n    SOA TTL, if add-soa was used. This has been fixed.\n  * When a query related to zone maintenance (NOTIFY, SOA) timed\n    out close to a view shutdown (triggered e.g. by rndc reload),\n    named could crash with an assertion failure. This has been\n    fixed.\n  * The statistics channel counters that indicated the number of\n    currently connected TCP IPv4/IPv6 clients were not properly\n    adjusted in certain failure scenarios. This has been fixed.\n  * Some servers that could not be reached due to EHOSTDOWN or\n    ENETDOWN conditions were incorrectly prioritized during server\n    selection. These are now properly handled as unreachable.\n  * On some systems the libuv call may return an error code when\n    sending a TCP reset for a connection, which triggers an\n    assertion failure in named. This error condition is now dealt\n    with in a more graceful manner, by logging the incident and\n    shutting down the connection.\n  * Changes to listen-on statements were ignored on reconfiguration\n    unless the port or interface address was changed, making it\n    impossible to change a related listener transport type. That\n    issue has been fixed.\n  * A bug in the keymgr code unintentionally slowed down some\n    DNSSEC key rollovers. This has been fixed.\n  * Some ISO 8601 durations were accepted erroneously, leading to\n    shorter durations than expected. This has been fixed\n  * A regression in cache-cleaning code enabled memory use to grow\n    significantly more quickly than before, until the configured\n    max-cache-size limit was reached. This has been fixed.\n  * Using rndc flush inadvertently caused cache cleaning to become\n    less effective. This could ultimately lead to the configured\n    max-cache-size limit being exceeded and has now been fixed.\n  * The logic for cleaning up expired cached DNS records was\n    tweaked to be more aggressive. This change helps with enforcing\n    max-cache-ttl and max-ncache-ttl in a timely manner.\n  * It was possible to trigger a use-after-free assertion when the\n    overmem cache cleaning was initiated. This has been fixed.\n  New Features:\n  * A new option signatures-jitter has been added to dnssec-policy\n    to allow signature expirations to be spread out over a period\n    of time.\n  * The statistics channel now includes counters that indicate the\n    number of currently connected TCP IPv4/IPv6 clients.\n  * Added RESOLVER.ARPA to the built in empty zones.\n  Feature Changes:\n  * DNSSEC signatures that are not valid because the current time\n    falls outside the signature inception and expiration dates are\n    skipped instead of causing an immediate validation failure.\n  Security Fixes:\n  * A malicious DNS client that sent many queries over TCP but\n    never read the responses could cause a server to respond slowly\n    or not at all for other clients. This has been fixed.\n    (CVE-2024-0760)\n  * It is possible to craft excessively large resource records\n    sets, which have the effect of slowing down database\n    processing. This has been addressed by adding a configurable\n    limit to the number of records that can be stored per name and\n    type in a cache or zone database. The default is 100, which can\n    be tuned with the new max-records-per-type option.\n  * It is possible to craft excessively large numbers of resource\n    record types for a given owner name, which has the effect of\n    slowing down database processing. This has been addressed by\n    adding a configurable limit to the number of records that can\n    be stored per name and type in a cache or zone database. The\n    default is 100, which can be tuned with the new\n    max-types-per-name option. (CVE-2024-1737)\n  * Validating DNS messages signed using the SIG(0) protocol (RFC\n    2931) could cause excessive CPU load, leading to a\n    denial-of-service condition. Support for SIG(0) message\n    validation was removed from this version of named.\n    (CVE-2024-1975)\n  * Due to a logic error, lookups that triggered serving stale data\n    and required lookups in local authoritative zone data could\n    have resulted in an assertion failure. This has been fixed.\n  * Potential data races were found in our DoH implementation,\n    related to HTTP/2 session object management and endpoints set\n    object management after reconfiguration. These issues have been\n    fixed.\n  * When looking up the NS records of parent zones as part of\n    looking up DS records, it was possible for named to trigger an\n    assertion failure if serve-stale was enabled. This has been\n    fixed. (CVE-2024-4076)\n","modified":"2026-03-11T07:27:08.928982Z","published":"2024-07-30T07:14:23Z","related":["CVE-2024-0760","CVE-2024-1737","CVE-2024-1975","CVE-2024-4076"],"upstream":["CVE-2024-0760","CVE-2024-1737","CVE-2024-1975","CVE-2024-4076"],"references":[{"type":"ADVISORY","url":"https://www.suse.com/support/update/announcement/2024/suse-su-20242636-1/"},{"type":"REPORT","url":"https://bugzilla.suse.com/1228255"},{"type":"REPORT","url":"https://bugzilla.suse.com/1228256"},{"type":"REPORT","url":"https://bugzilla.suse.com/1228257"},{"type":"REPORT","url":"https://bugzilla.suse.com/1228258"},{"type":"WEB","url":"https://www.suse.com/security/cve/CVE-2024-0760"},{"type":"WEB","url":"https://www.suse.com/security/cve/CVE-2024-1737"},{"type":"WEB","url":"https://www.suse.com/security/cve/CVE-2024-1975"},{"type":"WEB","url":"https://www.suse.com/security/cve/CVE-2024-4076"}],"affected":[{"package":{"name":"bind","ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP6","purl":"pkg:rpm/suse/bind&distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP6"},"ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"9.18.28-150600.3.3.1"}]}],"ecosystem_specific":{"binaries":[{"bind-utils":"9.18.28-150600.3.3.1"}]},"database_specific":{"source":"https://ftp.suse.com/pub/projects/security/osv/SUSE-SU-2024:2636-1.json"}},{"package":{"name":"bind","ecosystem":"SUSE:Linux Enterprise Module for Server Applications 15 SP6","purl":"pkg:rpm/suse/bind&distro=SUSE%20Linux%20Enterprise%20Module%20for%20Server%20Applications%2015%20SP6"},"ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"9.18.28-150600.3.3.1"}]}],"ecosystem_specific":{"binaries":[{"bind-doc":"9.18.28-150600.3.3.1","bind":"9.18.28-150600.3.3.1"}]},"database_specific":{"source":"https://ftp.suse.com/pub/projects/security/osv/SUSE-SU-2024:2636-1.json"}},{"package":{"name":"bind","ecosystem":"openSUSE:Leap 15.6","purl":"pkg:rpm/opensuse/bind&distro=openSUSE%20Leap%2015.6"},"ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"9.18.28-150600.3.3.1"}]}],"ecosystem_specific":{"binaries":[{"bind-doc":"9.18.28-150600.3.3.1","bind-utils":"9.18.28-150600.3.3.1","bind":"9.18.28-150600.3.3.1"}]},"database_specific":{"source":"https://ftp.suse.com/pub/projects/security/osv/SUSE-SU-2024:2636-1.json"}}],"schema_version":"1.7.5"}