{"id":"SUSE-SU-2026:3835-1","summary":"Security update for openssl, openssl-3","details":"This update for openssl, openssl-3 fixes the following issues:\n\nOpenSSL is updated to 3.5.0 in SLE-15-SP7: (jsc#PED-16072)\n\n* Enables Post-Quantum Cryptography (PQC) TLS support\n\nSecurity issues fixed:\n\n* CVE-2026-42764: NULL pointer dereference in QUIC server initial packet handling (bsc#1266347)\n* CVE-2026-34182: CMS AuthEnvelopedData Processing May Accept Forged Messages (bsc#1266344)\n* CVE-2025-9231: Fix timing side-channel in SM2 algorithm on 64 bit ARM (bsc#1250233)\n* CVE-2024-13176: Fix timing side-channel in ECDSA signature computation (bsc#1236136)\n\nPOWER performance enhancements:\n\n* Optimized MLDSA NTT, supports p8 and above architectures (jsc#PED-14569)\n\n- Adapt spec file for immutability via systemd-tmpfiles (jsc#PED-14813)\n- Fix check %{suse_version} \u003e 1600 (jsc#PED-15816)\n- Fix NULL pointer dereference when processing an OCSP response\n- Remove showciphers.c in favor of openssl ciphers\n- Use %ldconfig_scriptlets\n- Enable livepatching support for ppc64le [bsc#1257274]\n- Move ssl configuration files to the libopenssl package [bsc#1247463]\n- Don't install unneeded NOTES\n- Disable LTO for userspace livepatching [jsc#PED-13245]\n- Fix P-384 curve on lower-than-P9 PPC64 targets [bsc#1243014]\n- FIPS: Fix the speed command in FIPS mode for KMAC\n\n- FIPS: Restore the check to deny SHA1 signatures in FIPS mode and\n  the functionality to allow/deny via crypto-policies. [jsc#PED-12224]\n\nUpdate to 3.5.0:\n\n\n* Changes:\n\n    - Default encryption cipher for the req, cms, and smime applications\n      changed from des-ede3-cbc to aes-256-cbc.\n    - The default TLS supported groups list has been changed to include\n      and prefer hybrid PQC KEM groups. Some practically unused groups\n      were removed from the default list.\n    - The default TLS keyshares have been changed to offer X25519MLKEM768\n      and and X25519.\n    - All BIO_meth_get_*() functions were deprecated.\n\n  * New features:\n\n    - Support for server side QUIC (RFC 9000)\n    - Support for 3rd party QUIC stacks including 0-RTT support\n    - Support for PQC algorithms (ML-KEM, ML-DSA and SLH-DSA)\n    - A new configuration option no-tls-deprecated-ec to disable support\n      for TLS groups deprecated in RFC8422\n    - A new configuration option enable-fips-jitter to make the FIPS\n      provider to use the JITTER seed source\n    - Support for central key generation in CMP\n    - Support added for opaque symmetric key objects (EVP_SKEY)\n    - Support for multiple TLS keyshares and improved TLS key establishment\n      group configurability\n    - API support for pipelining in provided cipher algorithms\n\nChanges between 3.3.0 and 3.4.0:\n\n  * Changes:\n\n    - Deprecation of TS_VERIFY_CTX_set_* functions and addition of\n      replacement TS_VERIFY_CTX_set0_* functions with improved semantics\n    - The X25519 and X448 key exchange implementation in the FIPS provider\n      is unapproved and has fips=no property.\n    - SHAKE-128 and SHAKE-256 implementations have no default digest length\n      anymore. That means these algorithms cannot be used with\n      EVP_DigestFinal/_ex() unless the xoflen param is set before.\n    - Setting config_diagnostics=1 in the config file will cause errors to\n      be returned from SSL_CTX_new() and SSL_CTX_new_ex() if there is an\n      error in the ssl module configuration.\n    - An empty renegotiate extension will be used in TLS client hellos\n      instead of the empty renegotiation SCSV, for all connections with a\n      minimum TLS version \u003e 1.0.\n    - Deprecation of SSL_SESSION_get_time(), SSL_SESSION_set_time() and\n      SSL_CTX_flush_sessions() functions in favor of their respective _ex\n      functions which are Y2038-safe on platforms with Y2038-safe time_t\n\n  * New features:\n\n    - Support for directly fetched composite signature algorithms such as\n      RSA-SHA2-256 including new API functions\n    - FIPS indicators support in the FIPS provider and various updates of\n      the FIPS provider required for future FIPS 140-3 validations\n    - Implementation of RFC 9579 (PBMAC1) in PKCS#12\n    - An optional additional random seed source RNG JITTER using a statically\n      linked jitterentropy library\n    - New options -not_before and -not_after for explicit setting start and\n      end dates of certificates created with the req and x509 apps\n    - Support for integrity-only cipher suites TLS_SHA256_SHA256 and\n      TLS_SHA384_SHA384 in TLS 1.3, as defined in RFC 9150\n    - Support for retrieving certificate request templates and CRLs in CMP\n    - Support for additional X.509v3 extensions related to Attribute Certificates\n    - Initial Attribute Certificate (RFC 5755) support\n    - Possibility to customize ECC groups initialization to use precomputed\n      values to save CPU time and use of this feature by the P-256 implementation\n\nChanges between 3.2.0 and 3.3.0:\n\n  * Changes:\n\n    - Optimized AES-CTR for ARM Neoverse V1 and V2\n    - Various optimizations for cryptographic routines using RISC-V vector\n      crypto extensions\n    - Added assembly implementation for md5 on loongarch64\n    - Accept longer context for TLS 1.2 exporters\n    - The activate and soft_load configuration settings for providers in\n      openssl.cnf have been updated to require a value of [1|yes|true|on]\n      (in lower or UPPER case) to enable the setting. Conversely a value of\n      [0|no|false|off] will disable the setting.\n    - In openssl speed, changed the default hash function used with hmac from\n      md5 to sha256.\n    - The -verify option to the openssl crl and openssl req will make the\n      program exit with 1 on failure.\n    - The d2i_ASN1_GENERALIZEDTIME(), d2i_ASN1_UTCTIME(), ASN1_TIME_check(),\n      and related functions have been augmented to check for a minimum length\n      of the input string, in accordance with ITU-T X.690 section 11.7 and 11.8.\n    - OPENSSL_sk_push() and sk__push() functions now return 0 instead of -1\n      if called with a NULL stack argument.\n    - New limit on HTTP response headers is introduced to HTTP client.\n      The default limit is set to 256 header lines.\n\n  * Bug fixes and mitigations:\n\n    - The BIO_get_new_index() function can only be called 127 times before\n      it reaches its upper bound of BIO_TYPE_MASK and will now return -1\n      once its exhausted.\n\n  * new features:\n\n    - Support for qlog for tracing QUIC connections has been added\n    - Added APIs to allow configuring the negotiated idle timeout for QUIC\n      connections, and to allow determining the number of additional streams\n      that can currently be created for a QUIC connection.\n    - Added APIs to allow disabling implicit QUIC event processing for QUIC\n      SSL objects\n    - Added APIs to allow querying the size and utilisation of a QUIC\n      stream's write buffer\n    - New API SSL_write_ex2, which can be used to send an end-of-stream (FIN)\n      condition in an optimised way when using QUIC.\n    - Limited support for polling of QUIC connection and stream objects in a\n      non-blocking manner.\n    - Added a new EVP_DigestSqueeze() API. This allows SHAKE to squeeze multiple\n      times with different output sizes.\n    - The BLAKE2s hash algorithm matches BLAKE2b's support for configurable\n      output length.\n    - The EVP_PKEY_fromdata function has been augmented to allow for the\n      derivation of CRT (Chinese Remainder Theorem) parameters when requested\n    - Added API functions SSL_SESSION_get_time_ex(), SSL_SESSION_set_time_ex()\n      using time_t which is Y2038 safe on 32 bit systems when 64 bit time\n      is enabled.\n    - Unknown entries in TLS SignatureAlgorithms, ClientSignatureAlgorithms\n      config\n      options and the respective calls to SSL[_CTX]_set1_sigalgs() and\n      SSL[_CTX]_set1_client_sigalgs() that start with ? character are ignored\n      and the configuration will still be used.\n    - Added -set_issuer and -set_subject options to openssl x509 to override\n      the Issuer and Subject when creating a certificate. The -subj option\n      now is an alias for -set_subject.\n    - Added several new features of CMPv3 defined in RFC 9480 and RFC 9483\n    - New option SSL_OP_PREFER_NO_DHE_KEX, which allows configuring a TLS1.3\n      server to prefer session resumption using PSK-only key exchange over\n      PSK with DHE, if both are available.\n    - New atexit configuration switch, which controls whether the OPENSSL_cleanup\n      is registered when libcrypto is unloaded.\n    - Added X509_STORE_get1_objects to avoid issues with the existing\n      X509_STORE_get0_objects API in multi-threaded applications.\n    - Support for using certificate profiles and extened delayed delivery in CMP\n\n- FIPS: Mark SHA-1 as non-approved in the SLI. [jsc#PED-12224]\n\n- Introduce --without lto. When %{optflags} contains -flto=*, tests cases are\n  also built using -flto=* which significantly increases build times, this\n  option disables lto which improve iteration times when developing.\n\nUpdate to 3.2.4:\n\n- Remove the engines' directories and symlinks that were added to\n  allow parallel installations with openssl-1_1.\n- Add ktls capability [bsc#1216950]\n\nThis update also rebuilds nodejs24 to enable PQC.\n","modified":"2026-09-10T17:12:29.498189147Z","published":"2026-09-10T16:05:54Z","related":["CVE-2024-13176","CVE-2025-9231","CVE-2026-34182","CVE-2026-42764"],"upstream":["CVE-2024-13176","CVE-2025-9231","CVE-2026-34182","CVE-2026-42764"],"references":[{"type":"ADVISORY","url":"https://www.suse.com/support/update/announcement/2026/suse-su-20263835-1/"},{"type":"REPORT","url":"https://bugzilla.suse.com/1216950"},{"type":"REPORT","url":"https://bugzilla.suse.com/1243014"},{"type":"REPORT","url":"https://bugzilla.suse.com/1247463"},{"type":"REPORT","url":"https://bugzilla.suse.com/1250233"},{"type":"REPORT","url":"https://bugzilla.suse.com/1257274"},{"type":"REPORT","url":"https://bugzilla.suse.com/1266344"},{"type":"REPORT","url":"https://bugzilla.suse.com/1266347"},{"type":"WEB","url":"https://www.suse.com/security/cve/CVE-2024-13176"},{"type":"WEB","url":"https://www.suse.com/security/cve/CVE-2025-9231"},{"type":"WEB","url":"https://www.suse.com/security/cve/CVE-2026-34182"},{"type":"WEB","url":"https://www.suse.com/security/cve/CVE-2026-42764"}],"affected":[{"package":{"name":"openssl","ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP7","purl":"pkg:rpm/suse/openssl&distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP7"},"ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.5.0-150700.3.4.1"}]}],"ecosystem_specific":{"binaries":[{"libopenssl-3-fips-provider":"3.5.0-150700.5.45.2","libopenssl-3-fips-provider-32bit":"3.5.0-150700.5.45.2","libopenssl3-32bit":"3.5.0-150700.5.45.2","openssl-3":"3.5.0-150700.5.45.2","libopenssl-3-devel":"3.5.0-150700.5.45.2","openssl":"3.5.0-150700.3.4.1","libopenssl-devel":"3.5.0-150700.3.4.1","libopenssl-fips-provider":"3.5.0-150700.3.4.1","libopenssl3":"3.5.0-150700.5.45.2"}]},"database_specific":{"source":"https://ftp.suse.com/pub/projects/security/osv/SUSE-SU-2026:3835-1.json"}},{"package":{"name":"openssl-3","ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP7","purl":"pkg:rpm/suse/openssl-3&distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP7"},"ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.5.0-150700.5.45.2"}]}],"ecosystem_specific":{"binaries":[{"openssl":"3.5.0-150700.3.4.1","openssl-3":"3.5.0-150700.5.45.2","libopenssl-devel":"3.5.0-150700.3.4.1","libopenssl3-32bit":"3.5.0-150700.5.45.2","libopenssl3":"3.5.0-150700.5.45.2","libopenssl-3-devel":"3.5.0-150700.5.45.2","libopenssl-3-fips-provider":"3.5.0-150700.5.45.2","libopenssl-fips-provider":"3.5.0-150700.3.4.1","libopenssl-3-fips-provider-32bit":"3.5.0-150700.5.45.2"}]},"database_specific":{"source":"https://ftp.suse.com/pub/projects/security/osv/SUSE-SU-2026:3835-1.json"}},{"package":{"name":"nodejs24","ecosystem":"SUSE:Linux Enterprise Module for Web and Scripting 15 SP7","purl":"pkg:rpm/suse/nodejs24&distro=SUSE%20Linux%20Enterprise%20Module%20for%20Web%20and%20Scripting%2015%20SP7"},"ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"24.18.1-150700.15.18.1"}]}],"ecosystem_specific":{"binaries":[{"nodejs24-devel":"24.18.1-150700.15.18.1","nodejs24-docs":"24.18.1-150700.15.18.1","npm24":"24.18.1-150700.15.18.1","nodejs24":"24.18.1-150700.15.18.1"}]},"database_specific":{"source":"https://ftp.suse.com/pub/projects/security/osv/SUSE-SU-2026:3835-1.json"}}],"schema_version":"1.9.0"}